Segger 4.52c reports "The evalution period for this release has now expired"

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Segger 4.52c reports "The evalution period for this release has now expired"

      After my computer rebooted this morning, I'm now immediately getting an error when I launch SES 4.52c. The program immediately exits after pressing OK. I have a valid commercial license from Nordic and use J-Link programmers.

      I need to continue using this release to be in compliance with our quality assurance system. Furthermore SES 5.x modified the sscanf library compiler flags in a way that requires a change to our code base so we are not able to update, therefore the quality team will be hesitant to authorize an update.

      Why has it suddenly stopped working?
    • Hello,

      Thank you for your inquiry.
      The issue is that you are using Embedded Studio without a valid license which is a license violation...
      See here for how to fix the issue:
      wiki.segger.com/Embedded_Studio_evaluation_period_error

      So yes, you can keep using the V4.xx version of Embedded Studio but need a license and can't "evaluate" it anymore.

      Best regards,
      Nino
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/

      Or you can contact us via e-mail.