[SOLVED] SEGGER RTT over telnet

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SEGGER RTT over telnet

    I'm only able to make the telnet connection with the J-Link RTT Client V7.00 if there's also a connection with the J-Link RTT Viewer. Otherwise and all I'm getting is just:

    ###RTT Client: Connecting to J-Link RTT Server via localhost:19021 ..........

    Is that how it's intended to work?

    Im using STM32F407VG Discovery and JLink FW on the STLink hardware.
  • Hi,
    Thank you for your inquiry.

    dsc wrote:

    Is that how it's intended to work?
    Yes and no.
    The J-Link RTT Client requires an active J-Link debug connection,
    e.g. via an IDE, J-Link Commander, ...

    In your case, the J-Link RTT Viewer opens a debug connection to the device, which the RTT Client then hooks up to.
    As RTT Viewer and RTT Client are not supposed to be used at the same time,
    this choice is not optimal though.

    The simplest option here would be to connect to the device via the J-Link Commander (JLink.exe).
    Then the RTT Client can hook up to the Commander debug session.

    Does this answer your question?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.