[SOLVED] Debug under simulator SES + nRF52840 + S140

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Debug under simulator SES + nRF52840 + S140

    Is it posibile to do debug using Segger ES simulator for an example which uses also BLE stack?
    More specific I am trying to debug the blinky example found in
    When I start the debugger, the CPU is running, if I pause the debugger (break) the code stops somewhere in disassembler ; and it never reaches any part of main or startup .s files..
    I guess this is because the project somehow does not know how to load the softdevice hex into simulated MCU memory
    Is it posibile to do debug with simulator for examples which uses softdevice library?
    If yes, how? What should be done?
    I debugged another example - blinky with LED ; no BLE involved. This worked using simulator (with some tweak)
    IDE :
    SEGGER Embedded Studio for ARM
    Release 5.40c Build 2021022405.45437
    Windows x64
    OS ; windows 7
  • Hello,

    Thank you for your inquiry.
    The simulator will only simulate the Arm core itself, so you can check if your generic C/C++ or assembler code you wrote can generally run on the Arm platform.
    However peripherals are not part of the simulation which is why the application will fail as it waits for results from the peripheral which is not existent in the simulation.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.