[SOLVED] J-Link Plus Bricked During FW Update from Ozone

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link Plus Bricked During FW Update from Ozone

    I attempted to use Ozone for the first time targeting an nrf52. After attempting to launch a debug session with the Hello World project, I was prompted to update the firmware for my J-Link Plus. The firmware update failed and the debug probe is now apparently bricked. It no longer appears in J-Link Configurator.
  • Hi,
    Thank you for your inquiry.

    Usually, failed firmware updates do not brick a J-Link.
    It should still be recoverable in nearly all cases.

    In general:
    When using the J-Link it is important to have a stable USB connection.
    Please make sure, that the J-Link is directly connected to your PC via a solid USB cable.
    If you must use a USB-Hub, please make sure that it is externally powered.

    If this does not help:
    Could you please follow the troubleshooting article on the page linked below and send us a screenshot
    of the entire J-Link Commander output + answer the questions at the end of the article?
    wiki.segger.com/J-Link_cannot_…the_CPU#J-Link_connection

    Best regards,
    Fabian
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/


    Or you can contact us via e-mail.