How to download latest jlink-arm software with 32bir arm core support?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • How to download latest jlink-arm software with 32bir arm core support?

      Dear All,

      I wanna use RPi-Zero-W with Jlink as standalone programmer.
      I have discovered that 32bit arm core support is dropped from V6.82g release.
      And so could you please help me to download latest jlink arm toolchain supporting 32bit arm cores?

      Thanks.
    • Hi,
      Thank you for your inquiry.

      I am not quite sure if I understood you correctly.
      Are you referring to the J-Link Software Pack?
      The J-Link Software and Documentation Pack is still available for ARM / Raspberry Pi here:
      segger.com/downloads/jlink/#J-…twareAndDocumentationPack

      Screenshot:



      Best regards,
      Fabian Federschmidt
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/


      Or you can contact us via e-mail.
    • Thanks for your quick reply.
      Because of RPi-Zero-W board has arm 32bit arm mcu on it, JlinkExe(from Jlink sotware pack v.698a) is crashing with SegFault on latest Raspberrypi-OS.

      I am trying to run "Jlink Software Pack" from newest to oldest on RPi-Zero-W.
      I have tried from v6.98a to 6.94 but SegFault problem is still exist.

      From this thread i learned that 32bit support is dropped from a specific version of "Jlink software Pack".
      [SOLVED] SegFault / Illegal Instruction starting with Flasher V6.84 on RaspberryPi B+ (ARMv6)

      could you tell me what is the latest release supports 32bit arm cores without segfault error?

      Thanks.
    • Additionally, all versions of JLink Software Pack are working on RaspBeryPi Model 3+ without any error.
      Same software, same operation system (raspbery OS) only hw is different.

      Could you please help me how work on RPi-Zero-W ?

      Thanks.
    • Hi,

      It is not a matter of 32-bit and 64-bit.
      As Fabian wrote, we DO HAVE a 32-bit ARM version.
      The problem is more the architecture.

      Almost all Raspberry Pi derivatives and their alternatives (Orange Pi, Odroid, NVIDIA Jetson, ...) are either ARMv7-A (Cortex-A8, A9, ...) or ARMv8-A (Cortex-A53, A72, ...) based.
      While v7-A is always 32-bit, v8-A supports 64-bit and a 32-bit mode which is compatible to v7-A.

      The Linux ARM 32-bit version of J-Link is compiled for v7-A. The 64-bit version for v8-A.
      The Raspberry Pi Zero-W is one of the very rare remaining ARMv6 based Linux ARM systems in the world.

      Long story short:
      ARMv6 based systems are not supported by current versions. v7-A is minimum.
      There are no plans to change this as ARMv6 is legacy and almost not present anymore (If I remember correctly, the last standard Raspberry that was v6 was the Raspberry Pi 1 and they are at Raspberry Pi 4B now)

      BR
      Alex