Systemview timeline is not always drawn correctly

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Systemview timeline is not always drawn correctly


      I am evaluating systemview and have encountered the following issue:

      After loading the data file (see attached: out.svdat) , the timeline view is not drawn correctly.
      The rectangles showing the task runtimes are missing, but it seems that the times the tasks are blocked are drawn as they should (see attached file: after_loading.png)
      If I zoom a few times in and out, and also use the slider at the bottom a few times, then it appears correctly (see attached: after_zooming_and_scrolling.png)
      After it appears correctly, it might dissapear again, especially if I scroll/zoom fast.

      I am using 3.3.0 64 bit . I have also tried 3.3.0 32 bit and have tried 3.2.0 32 bit all having the same problem.

      Any hints ?

      Thank you !
    • Hello,

      Thank you for your inquiry.
      What RTOS are you instrumenting here?
      It appears that the code instrumentation is not done correctly.
      How to do this is explained in the SystemView manual in detail.

      If you are looking to instrument a non RTOS application, see here for a guide:

      Best regards,
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system:

      Or you can contact us via e-mail.