j-link is not recognized by stm32cubeIDE on Ubuntu

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • j-link is not recognized by stm32cubeIDE on Ubuntu

      Dear forum,


      I am using:

      • Notebook with Ubuntu 20.10
      • stm32f3discovery (on it: STM32F303)
      • Development environment: Stm32CubeIDE1.5.1

      When I try to program or debug the STM32, I get an error message (see attachment: 'Error-report.png')


      The console of the IDE also writes the following report:

      Connecting to J-Link ...
      Connecting to J-Link failed.
      Connected correctly?
      GDBServer will be closed ...
      Shutting down ...
      Could not connect to J-Link.
      Please check power, connection and settings.




      The J-Link itself is recognized by Ubuntu (I tested it by typing ‘lsusb’ in the terminal - see attachment: 'JLink_recognized.png').



      I have another notebook with Windows 10 and the debug settings are exactly like on Ubuntu (see attachment: 'Debugger_configuration.png'). But on Windows 10 it works!


      Can someone help me or give me tips as to why it is on my Ubuntu might not work?


      Thanks in advance!
      Images
      • Debugger_configuration.png

        109.28 kB, 1,038×757, viewed 20 times
      • Error-report.png

        53.26 kB, 448×628, viewed 16 times
      • JLink_recognized.png

        68.15 kB, 786×533, viewed 21 times
    • Hi,
      Thank you for your inquiry.
      There is no such issue known to us.

      Could you please give the latest J-Link Software Pack a try?
      segger.com/downloads/jlink#J-L…twareAndDocumentationPack

      After installing the deb package, could you please try to connect to the J-Link via the J-Link Commander (JLinkExe)?
      If you only have one J-Link connected, it should detect it automatically after start.
      If it does, could you please update the J-Link GDBServer files with the updated ones from the package and try again?
      Does it work now?
      If not, could you please make sure that the port 2331 is not occupied already?

      A tutorial for setting up CubeIDE with J-Link can be found here:
      wiki.segger.com/STM32CubeIDE

      Best regards,
      Fabian
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/


      Or you can contact us via e-mail.