[ABANDONED] How to fix "Error while recording" and/or overflows

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] How to fix "Error while recording" and/or overflows

    I'm trying to use SystemView for the first time in a real situation & even though I've followed the manual I'm still getting either overflows (occasionally) or "Error while recording" (pretty much the rest of the time) or just no captured data when I start recording.

    In about 100 attempts I've managed to capture 2 or 3 relatively short traces (maybe a few hundred ms of data) & those seem to be showing the task/interrupt interactions as I'd expect, so it appears to be nearly working at least some of the time - and the information it shows for these runs is looking very promising.

    H/w is based on the NXP LPC4357 in TQFP package, using the M4 core clocked @ 144MHz & running embOS v4.14 with the embedded system view v2.52a files included in the project
    Toolchain is IAR v7.80.4

    I've got a j-link pro connecting from the PC to the target & am running with no other traffic on the debug port (but debugging in IAR & using Segger RTT messages at other times all seem to work just fine, so I believe that the debug connections are working).
    I've tried SWD @4, 8, 10 & 12 kHz but that doesn't seem to make any difference.
    I've set the RTT buffer up to allow 8k in internal SRAM for the Systemview data

    I've tried both v2.52 & v3.20 SystemView apps on the PC but again have not seen any real difference in success.

    I'd appreciate your suggestions about what to try in order to get a better success rate in capturing the data from the target

    Please let me know any other information you need about the setup to help me proceed

  • Hello Jez,

    Thank you for your inquiry.

    JezC3128 wrote:

    I've tried SWD @4, 8, 10 & 12 kHz but that doesn't seem to make any difference.
    Can you confirm you mean kHz and not MHz? If yes, that might already be the source of the issue. Try >20 MHz.
    What error message are you getting exactly? Could you provide a screenshot?
    Could you do the testing with the latest V3.20?
    V2.52 is no longer in maintenance and support.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.