[SOLVED] MKRWAN Bootloader - mkrwan appears unresponsive

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] MKRWAN Bootloader - mkrwan appears unresponsive

    Hi,

    I have been having challenges for a while with using the Segger JLink on my MKRWAN and using VSCode too debug. It wouldn’t work and would just stop responding.

    With the help of this and other forums, I concluded that the tool (or I) had somehow damaged the boot loader and I tried to re-install the boot loader that is on the Arduino Core GitHub repository.

    I am using Segger EDU Mini as my debugging tool, running on a Mac OS, so last night I went through a forum post to programme the boot loader, now my Arduino is completely unresponsive to the USB port, but is responding to the debugger.

    The process I followed was to connect via the JLinkExe toolset
    connect
    loadbin sam-d21-sam-ba-arduino-mkrwan1310.bin,0
    reset

    It all reported ok, but now when I double tap the reset button, the mkrwan doesn’t respond and it appears the usb connection is not working. The only lights on the board are the power light (green permanently on) and battery charging (yellow fast flashing), the latter I think means the battery charger chip is not connected to either a battery or the processor.

    I had search around the internet last night, but I couldn’t find anything that suggested a resolution.
    They tell me I’m a grown up, I just want to play.
  • I fixed it.

    Instead of using JLink, I eventually swapped to JFlashLite and rather than using the bin file, I instead used the hex file. After a reset, it worked successfully.

    It does suggest that loadbin might not work as well as JFlashLite.

    I’ll know for the future
    They tell me I’m a grown up, I just want to play.
  • Actually, it more sounds like you either had a bad/incomplete bin file or flashed it to the wrong address, so J-Link is probably the wrong thing to blame here.
    J-Flash Lite uses EXACTLY the same flash programming logic as JLink.exe does.
  • HI Alex,

    Not knowing the internal functionality between the 2 applications, I agree that it is also equally possible that the bin file was corrupted.

    thanks for your feedback.
    They tell me I’m a grown up, I just want to play.