[SOLVED] TI Code Composer Studio 10.1.1 and JLink Pro with FW 6.88 & 6.88a

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] TI Code Composer Studio 10.1.1 and JLink Pro with FW 6.88 & 6.88a

    Good day,
    I've recently updated firmware of my J-link Pro to ver 6.88 from J-link Configurator V6.88, upgrade process passed without any problem but CCS rejected to connect to MCU and I got message (please see pic1).
    I updated CC Studio from download.segger.com/J-Link/JLink_TI_CCS_plugin_unified with latest driver for JLINK, and could not connect to the target mcu as as well, with error message showed on pic. 3. I though that problem was in Segger Link settings (pic. 6), but all looks OK, I check all paths and files, all looks good, and made one more test and found that J-Link could connect to target mcu by J-Link Commander ( pics 5 and 6), so all hw is in working condition.

    My question is : what else I can check or test for resolve such kind of problem ? Because do not want return back ti xds100 after work with j-link.

    small update, I tried to use software package 6.88a with JLink, and got same story as above. I suppose that problem somewhere in around JLinksctipt file, because randomly got couple success connections with mcu, but what was reason, I can't explain, may be because MCU was in some spacial state after manipulation from JLink Commander
    .
    May be someone can advice how to make log of JLink activity when it busy with CCS debugging, because logging from from CCS does not work? It should give us idea what to do next.

    I did not have such kind of problem before, all project setup process was quite simple and user friendly, but I could not "roll back" to some working stage , because on download.segger.com/J-Link/JLink_TI_CCS_plugin_unified is version 6.88.0 only.
    Images
    • Segger_Porblem_1.png

      38.95 kB, 676×405, viewed 69 times
    • SeggerJLink_Problem3.jpg

      46.96 kB, 908×405, viewed 50 times
    • SeggerJLink_Problem4.jpg

      73.35 kB, 819×492, viewed 53 times
    • SeggerJLink_Problem6.jpg

      74.76 kB, 1,271×436, viewed 47 times
    • SeggerJLink_Problem5.jpg

      151.28 kB, 781×702, viewed 55 times

    The post was edited 2 times, last by KGA ().

  • Something reg. your statements cannot be correct.
    As can be clearly seen in the screenshots, the message box from CCS shown J-Link V6.44b and not V6.88 like the Commander etc.
    Without having checked the release notes I would say that the TMS570LS20216 has been added/implemented in a later version...

    You should check your setup.
    CCS is definitely NOT using V6.88 / V6.88a
  • Good day Alex,
    I'm appreciate for prompt response.
    Probably, my initial explanation was not clear enough and pictures made you confused.

    But our story is quite simple :
    1. We have been using JLink & CCS since for last 8 months , since got it from Element14.
    2. Everything worked well for CCS with version below 10.0.x
    3. The CCS was updated to latest version approx. 5-6 days before. The JLink drivers for CCS was updated to ver.6.88.0 as well.
    4. After we had found unpleasant thing : JLink stop to recognize of MCU(TMS570LSxxxx) of our project. (as showed on pic.1).
    5.Segger software pack 6.x (I do not remember exactly version ) was removed by Segger Remove.
    6.Latest software pack from Segger (ver6.88) was installed.
    7.The device JLINK FW was upgraded to 6.88 by JLink Commander and after mcu flashing & debugging of our project n CCS stop to work.(pic. segger_problem_3)
    8.Our device hardware : mcu ,connections, cable was tested from JLink Commander, all worked correct ( pic 4, pic 5).
    9.I tried Segger V6.88a software pack(drivers,FW for JLink), without any success.
    10. Pic.6 shows new interface of target connection,was found fault with CCS JLink Log creating, therefore we could not trace what was wrong during programming the mcu.

    Please feel free to ask any additional questions.

    The post was edited 2 times, last by KGA ().

  • Hello,

    I understood it that way but thanks for summarizing to avoid misunderstandings.
    This does not change the fact that pic1 shows "V6.44b" in the message box title and not "V6.88".
    Do you agree?
    So the fact that the message box shows a version != V6.88 indicates that your CCS installation is *not* using a V6.88 version of the J-Link software.

    Moreover, since you are using V6.44b in CCS (according to the screenshot in pic1) the error message makes sense
    because if you look up the release notes, the ones for V6.44e (3 versions later) indicate that there was a bug that made CCS device names to not be recognized.

    Short:
    Your CCS installation is *not* using V6.88, otherwise it would just work because the V6.44e fix would have been applied.
    The message box title confirms that contrary to your sayings, CCS is not using V6.88.


    BR
    Alex
  • Hi Alex,
    Thank you for prompt response.

    Just small clarification:

    >> So the fact that the message box shows a version != V6.88 indicates that your CCS installation is *not* using a V6.88 version of the J-Link software
    Yes, pic. 1 I got when I made upgrade of CSS ver. 10.0.0.xxx to 10.1.1.0004.
    And as soon as found that Segger stop support Mcu what I had using last 6 months I made decision to upgrade Segger J-link support for CSS as well.
    and used CCS Install New Software option.Pls. see pic 6. it's point 3 of my story.

    3a. The CSS suggested to upgrade firmware of JLInk, but I downloaded Segger link Software Pack and made upgrade by Commander or Configurator ( I don't remember).

    >>Moreover, since you are using V6.44b in CCS (according to the screenshot in pic1) the error message makes sense
    yes, it was in begin my way.

    >>because if you look up the release notes, the ones for V6.44e (3 versions later) indicate that there was a bug that made CCS device names to not be recognized.
    Actually, I did not know about any bugs it. before was ok.

    >>Your CCS installation is *not* using V6.88, otherwise it would just work because the V6.44e fix would have been applied.
    Ok, how I can check what is rev segger's plug in installed in my current CCS ?


    Images
    • Segger_6.jpg

      51.16 kB, 956×314, viewed 36 times

    The post was edited 1 time, last by KGA ().

  • Hello,

    We are currently investigating an issue with TMS570LS devices and the latest CCS plugin.
    It is not related to the "The selected device xxx is unknown to this version of the J-Link software" dialog you are getting but may cause debugging to not work.
    I recommend to wait for the new version that fixes the issue we are currently investigating and take it from there.


    BR
    Alex
  • SEGGER - Alex wrote:

    Hello,

    We are currently investigating an issue with TMS570LS devices and the latest CCS plugin.
    It is not related to the "The selected device xxx is unknown to this version of the J-Link software" dialog you are getting but may cause debugging to not work.
    I recommend to wait for the new version that fixes the issue we are currently investigating and take it from there.


    BR
    Alex
    Hi Alex,

    I am having the same problem with the new version. I use TMS570LC4357. The Segger is a J-Link v7.0. I can use other software (Segger IDE or UniFlash) but CCS gives the error in OP.

    Is there a way to roll back the version to an earlier J-Link Support version? I can only seem to access 6.88 but an earlier version from September would resolve the problem for now.