[SOLVED] Why I get Vtref = 0.000V when I debugged nrf52832 with J-Link debugger

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Why I get Vtref = 0.000V when I debugged nrf52832 with J-Link debugger

    Hello, I am debugging my custom board with J-link debugger. The board has nRF52832 as MCU and the power supply is 2.5V. When I debugged the nRF52832 with J-Link, it failed and the error showed " Vtref = 0.000V". But I check the Voltage on the debug port and the voltage is 2.5V. I followed the manual and use the 20-pin connect cable.

    Pin 1 connected to VCC on board. SWDIO connected to Pin 26 of nRF52832, SWCLK connected to Pin 25 of nRF52832, and GND to GND on board.
    The error is shown below.
    How can I debug the problem? Thanks
    Images
    • error1.jpg

      108.93 kB, 1,522×640, viewed 37 times
    • pin.png

      167.77 kB, 1,522×499, viewed 32 times
  • I just connect the Pin1 and Pin4 of the cable to a cell battery which voltage is 3.3V. But the J-Link Debugger still found Vtref = 0.000V. So wired. Do I need to buy some cable for SWD interface?
    Images
    • WeChat Image_20201116035644.jpg

      120.99 kB, 1,440×1,080, viewed 28 times
    • WeChat Image_20201116035656.jpg

      164.83 kB, 1,440×1,080, viewed 26 times
  • Hi,

    At least on the photo, you have NOT connected the battery to pin 1.
    Pin 1 is indicated by the BLUE wire on the cable.
    Maybe that‘s also the problem on your custom board wiring: Wrong direction of the debug connector...

    BR
    Alex