[SOLVED] Could not open J-Link shared library. Exiting now

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Could not open J-Link shared library. Exiting now

    I have installed seggar systemview in my ubuntu 20.04. But when I try to run sytemview in my terminal, it gives an error.

    Could not open J-Link shared library. Exiting now.

    I followed the below link to solve the issue but I am unable to find /lib64/libudev.so.1 in my pc. I have also tried to install the latest version of JLink, but the installation failed with error.

    dpkg: error processing archive JLink_Linux_V684a_x86_64.deb (--install):
    trying to overwrite '/etc/udev/rules.d/99-jlink.rules', which is also in package segger-jlink-udev-rules 6.56a.

    How to install the below missing dependencies.?

    blackfly@BlackFly:~/Downloads/SystemView_Linux_V252d_x86_64$ ldd SystemView
    linux-vdso.so.1 (0x00007ffdad7c9000)
    libQtGui.so.4 => not found
    libQtCore.so.4 => not found
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f19eaf99000)
    libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f19eadb8000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f19eac69000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f19eac4e000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f19eaa5a000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f19eaa4f000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f19eaa49000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f19eafda000)

  • The dependencies problem solved when I installed the latest version Systemview. But, Its seems like I not able to install stm32ide, jlink and systemview together. I have to remove stm32cube ide inorder to install jlink, at the same time I have remove jlink to install stm32cude ide. Any solution? I need some serious help guys.

    The post was edited 2 times, last by Praveen ().

  • You need to install jlink dependency.

    Instead of having it installed as system-wide dependency, you can download and extract the tar.gz version and use LD_LIBRARY_PATH.

    E.g. install jlink libraries system-wide and install STM32Cube to a local directory

    BTW your first post mentions you are missing the Qt4 dependency. So you first need to install Qt4 libraries first.

    In older Ubuntus it used to be like: "sudo apt-get install -y qt4-default"

    But 20.04 removed Qt4 libraries, so you need to install them manually: ubuntuhandbook.org/index.php/2…install-qt4-ubuntu-20-04/
  • Hi,

    (please also take my comments with a grain of salt, I have just had a short look at the Linux tools yet, so I might be wrong.)

    do not install Qt4 manually.

    It is unmaintained and out of support for five years. The Segger tools ship with their own copy of Qt4, which might be tailored to their needs and might have security fixes added.

    Source Code

    1. $ l /opt/SEGGER/JLink_V684a/libQt*
    2. -rwxr-xr-x 1 root root 3078576 Sep 7 18:29 /opt/SEGGER/JLink_V684a/libQtCore.so.4.8.7
    3. -rwxr-xr-x 1 root root 11213008 Sep 7 18:29 /opt/SEGGER/JLink_V684a/libQtGui.so.4.8.7

    So if those libs cannot be found, there is another problem. I had the same problem with Ozone and Segger support fixed it. So I would wait for them to comment.


    The post was edited 2 times, last by icwiener ().

  • Hello,

    Thank you for your inquiry.
    The original error message indicates that the JLink library could not be found due to the failed installation.
    Make sure to install the J-Link software with sudo in the default folder.
    If everything went correctly SystemView should now be able to find the library.

    Also as the poster above mentioned please do not install random Qt libraries. Always only use the ones provided with the SEGGER software.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.