[ABANDONED] Renesas RA6M3 and Jlink

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Renesas RA6M3 and Jlink

    I am trying to flash my Renesas RA6M3 using JLink Commander CLI on a Win10 VM.
    I tried to erase the device first for downloading the compiled mbed OS firmware into it.
    However, I am not able to proceed with erase.

    This is the CLI output:

    Microsoft Windows [Version 10.0.19041.450]
    (c) 2020 Microsoft Corporation. All rights reserved.

    C:\Users\crist>JLink -device R7FA6M3AH -AutoConnect 1 -if SWD -speed auto
    SEGGER J-Link Commander V6.84a (Compiled Sep 7 2020 17:27:40)
    DLL version V6.84a, compiled Sep 7 2020 17:26:08

    Connecting to J-Link via USB...O.K.
    Firmware: J-Link Lite-Cortex-M V9 compiled May 17 2019 09:50:01
    Hardware version: V9.00
    S/N: 519004119
    License(s): GDB
    Device "R7FA6M3AH" selected.

    Connecting to target via SWD
    Found SW-DP with ID 0x5BA02477
    Found SW-DP with ID 0x5BA02477
    Unknown DP version. Assuming DPv0
    Scanning AP map to find all available APs
    AP[2]: Stopped AP scan as end of AP map has been reached
    AP[0]: AHB-AP (IDR: 0x24770011)
    AP[1]: APB-AP (IDR: 0x44770002)
    Iterating through AP map to find AHB-AP to use
    AP[0]: Core found
    AP[0]: AHB-AP ROM base: 0xE00FF000
    CPUID register: 0x410FC241. Implementer code: 0x41 (ARM)
    Found Cortex-M4 r0p1, Little endian.
    FPUnit: 6 code (BP) slots and 2 literal slots
    CoreSight components:
    ROMTbl[0] @ E00FF000
    ROMTbl[0][0]: E000E000, CID: B105E00D, PID: 000BB00C SCS-M7
    ROMTbl[0][1]: E0001000, CID: B105E00D, PID: 003BB002 DWT
    ROMTbl[0][2]: E0002000, CID: B105E00D, PID: 002BB003 FPB
    ROMTbl[0][3]: E0000000, CID: B105E00D, PID: 003BB001 ITM
    ROMTbl[0][4]: E0040000, CID: B105900D, PID: 000BB9A1 TPIU
    ROMTbl[0][5]: E0041000, CID: B105900D, PID: 000BB925 ETM
    ROMTbl[0][6]: E0042000, CID: B105900D, PID: 002BB908 CSTF
    ROMTbl[0][7]: E0043000, CID: B105900D, PID: 001BB961 TMC
    ROMTbl[0][8]: E0044000, CID: B105F00D, PID: 001BB101 TSG
    Cortex-M4 identified.
    Without any give address range, Erase Chip will be executed
    Erasing device...
    J-Link: Flash download: Total time needed: 0.234s (Prepare: 0.167s, Compare: 0.000s, Erase: 0.061s, Program: 0.000s, Verify: 0.000s, Restore: 0.006s)
    J-Link: Flash download: Total time needed: 2.182s (Prepare: 0.092s, Compare: 0.000s, Erase: 2.083s, Program: 0.000s, Verify: 0.000s, Restore: 0.005s)
    J-Link: Flash download: Total time needed: 0.251s (Prepare: 0.092s, Compare: 0.000s, Erase: 0.151s, Program: 0.000s, Verify: 0.000s, Restore: 0.007s)

    ****** Error: Communication timed out: Requested 20 bytes, received 0 bytes !

    ****** Error: Failed to erase sectors.

    J-Link: Flash download: Total time needed: 22.980s (Prepare: 0.010s, Compare: 0.000s, Erase: 22.958s, Program: 0.000s, Verify: 0.000s, Restore: 0.011s)

    ****** Error: Failed to restore target. RAMCode never stops
    ERROR: Erase returned with error code -5.

    I also tried with the JFlashLite GUI. Same issue. Couldn't erase. Any help would be appreciated.
    Thanks in advance.
  • Hi,
    Thank you for your inquiry.
    There is no issues known to us related to RA6M devices.

    Do you use custom hardware or an evaluation board? In the latter case which one?
    If custom hardware, do you experience the same problem on an evaluation board?
    Could you please send us a J-Link log file? How to enable:
    What OS are you running this VM on and which VM program do you use for it?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.