[SOLVED] FreeRTOS IAR - Error[2]: Failed to open #include file 'stdarg.h'

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] FreeRTOS IAR - Error[2]: Failed to open #include file 'stdarg.h'

    Hi to all,
    I add SystemViwer to ma FreeRTOS Project.
    To build Project i use IAR for ARM 8.40.2 for STM32F429ZI.

    I do these steps for install Systemview in target
    1. Add the SYSVIEW and RTT core modules to the project
    2. Include SEGGER_SYSVIEW_Config_FReeRTOS.c in the project.
    3. At the end of FreeRTOSConfig.h or before every FreeRTOS.h add #include "SEGGER_SYSVIEW_FreeRTOS.h"
    4. In FreeRTOSConfig.h define INCLUDE_xTaskGetIdleTaskHandle as 1.
    5. In FreeRTOSConfig.h define INCLUDE_pxTaskGetStackStart as 1.
    6. Apply the patch file to the FreeRTOS kernel sources.
    7. Call SEGGER_SYSVIEW_Conf() in main after target initialization.

    When I build Project i have a error of #include <stdarg.h> in SEGGER.h: "Error[2]: Failed to open #include file 'stdarg.h' "
    Somebody can help me?

    Regards, Luca
  • Hello Luca,

    Please note that this is a IAR project setup specific question which is not a SEGGER product.
    For questions on how to use the IAR IDE we recommend contacting IAR support.

    This thread will be closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.