AppWizard fails to export when solution is pulled from source control

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • AppWizard fails to export when solution is pulled from source control

      Hello,

      I am having trouble getting my AppWizard solution to export when it is pulled from source control (TFS). I've tested this on an empty solution where I created a new AppWizard project and checked in the root folder where the project is located into source control (this includes any .dll and .lib files).

      I then delete the project root folder locally and get the latest from source control (The goal for this test is to make sure it works out of the box from source control). The Visual Studio solution works fine and builds, but the actual AppWizard project file does not build. When I select export and save in AppWizard I get this error: ..\..\Source\APP_MainWindow.cpp: Export failed in APP_MainWindow::OnFileExport. I've attached the error dialog to this post.

      It appears that there is something else going on in the AppWizard project folder, perhaps the project is looking for files somewhere else outside the AppWizard project folder? This error is reproducible on a new empty project. Any help is appreciated and thanks!
      Images
      • 2020-09-01 02_58_30-AppWizard V1.00_6.10f - PendantUI.png

        7.84 kB, 487×186, viewed 38 times
    • Hi,

      Not sure yet why this happens. Are the files write protected?

      I will give it a try on my end, too.

      EDIT:
      I gave it a try. My version control sets the file properties to write protected. When the files are write protected I get the same error as you do. After removing the write protection it is working.

      Regards,
      Sven