[SOLVED] J-Link Read Low Voltage

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link Read Low Voltage

    I am using a J-Link with Windows 10 version 6.80d

    Application log started
    - J-Flash V6.80d (J-Flash compiled Jun 26 2020 17:16:35)
    - JLinkARM.dll V6.80d (DLL compiled Jun 26 2020 17:16:09)


    I am using the 10pin adapter to communicate with the MCU.

    I am able to erase, and program the NXP MIMXRT1064xxx6a MCU.

    I am able to use the MCUXpresso IDE to download and debug my application.

    When I go to read sectors, I get

    WARNING: Supply voltage too low or too high, disconnecting target! VTarget = 0.909V or 0.0V

    I notice that the middle green light of the J-Link goes out when I initiate a read.

    Most of the time the read fails, but I am occasionally able to read 64K.

    If I read the entire chip, 4MB, 8 sectors are read before the 'supply voltage' error occurs. The middle green light is out during the 8 sector read.

    Any suggestions as to what is causing this behavior?
  • Hi,
    Thank you for your inquiry.

    From your post, it Looks like there is a power issue.
    Could you please make sure that
    - the J-Link is directly connected to the PC, and not to a USB-Hub
    - the Device is correctly powered externally.

    Are you using the J-Link you registered with?
    The S/N of that J-Link is from a unit from 2012 which is out of support and maintenance.
    We recommend to make use of our trade-in program:
    segger.com/purchase/trade-in-program/

    Best regards,
    Fabian Federschmidt
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/


    Or you can contact us via e-mail.