[SOLVED] J-Flash V6.82c stopped working from command line

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Flash V6.82c stopped working from command line

    Dear friends at Segger,

    the latest versions of J-Flash no longer seem to work when driven by command line. :(
    The files .cfg/.dat are not created, although the software does not report any error.
    We tried with the latest Beta version (6.83b), but that does not work either. We then reverted to a previous version (6.80e), which works fine.

    Here is the log taken from J-Flash V6.82c, from which you can see all of our command-line parameters.
    Strangely, when supposed to create the output .cfg/.dat files, it actually seems to overwrite the input file, in the example [Firmware\DFWLLR1_Release_YL.bin].

    Application log started
    - J-Flash V6.82c (J-Flash compiled Jul 31 2020 17:37:19)
    - JLinkARM.dll V6.82c (DLL compiled Jul 31 2020 17:36:49)
    Optional command line parameters found
    - [1]: -openprjDFWLLR1.jflash
    - [2]: -openFirmware\DFWLLR1_Release_YL.bin,0x8000000
    - [3]: -savecfgFirmware\WLL_0001.cfg
    - [4]: -savedatFirmware\WLL_0001.dat
    - [5]: -saveprj
    Reading flash device list [C:\Program Files (x86)\SEGGER\JLink\ETC/JFlash/Flash.csv] ...
    - List of flash devices read successfully (451 Devices)
    Reading MCU device list ...
    - List of MCU devices read successfully (7837 Devices)
    Opening project file [DFWLLR1.jflash] ...
    - Project opened successfully
    Opening data file [Firmware\DFWLLR1_Release_YL.bin] ...
    - Data file opened successfully (325952 bytes, 1 range, CRC of data = 0xC0EC090B, CRC of file = 0xC0EC090B)
    Saving data file [Firmware\DFWLLR1_Release_YL.bin] ...
    - Data file saved successfully (325952 bytes, 1 range)
    Saving data file [Firmware\DFWLLR1_Release_YL.bin] ...
    - Data file saved successfully (325952 bytes, 1 range)
  • Hi,
    Thank you for your inquiry.
    We will look into this as soon as possible.

    I will keep you updated.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • Hello,

    I´ve realy the same problem with my command line.
    My command line look´s like this: "C:\Program Files (x86)\SEGGER\JLink\jflash.exe" -openprj"ArmBinBuilder\net5-FB.jflash" -open"hex\%1_V%2.%3.%4.hex" -savecfg"hex\Flasher.cfg" -savedat"hex\Flasher.dat" -exit
    It works at Version 6.80, but not on 6.82c and also on the 6.82d Version.
    What I´ve seen if I removed the "-exit" option, is that the JFlash writes it´s data to the original source file, in my case the .hex file.
    No Output of cfg or dat File are created.


  • Hello,

    we have successfully determined the root cause for this.
    With the version V6.82 of J-Flash, a bug was introduced unintentionally,
    causing the command line options "-savedat" and -"-savecfg" to no longer work correctly.
    We have fixed the behavior of J-Flash internally already.

    Thank you very much for reporting this issue.

    A version which contains the fix is planned to be released later this week.

    Sorry for any inconveniences caused by this.
    Best regards,