[SOLVED] SystemView Windows 10 cannot capture data normally

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SystemView Windows 10 cannot capture data normally

    I used the J-Trace attached Cortex-M Trace Reference Board to test the Systemview function, and found that the event cannot be captured normally under the windows10 system, and an error has been reported. If use a virtual machine to run the ubuntu system, there is no problem. I use J-Trace Streaming Trace tutorial project running without any modification.

    Project link: wiki.segger.com/Tracing_on_ST_…-M_Trace_Reference_Board)
    • Log1.PNG

      42.88 kB, 513×530, viewed 59 times
    • setting.PNG

      9.23 kB, 385×400, viewed 57 times
  • Hello,

    Thank you for your inquiry.
    The reported behaviour is known to us and is due to an issue with the J-Link DLL. If you use the same J-Link software version on your Ubuntu system you would see the same behaviour.
    Simply install the latest J-link software package on your Windows PC and everything should be working again as before:

    Could you verify this?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.