[SOLVED]Error writing firmware to device

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED]Error writing firmware to device


    I am using the following commands for programming my NRF52 based custom board:

    nrfjprog -f nrf52 --program fimrware.hex --sectorerase --log
    nrfjprog -f nrf52 --reset

    It was working properly, but suddenly it stopped, and now I get the following log (attached in a file)

    I have also triend using J-Link commander, and I get the following

    loadfile "firmware.hex"
    Downloading file [firmware.hex]...
    Writing target memory failed.

    I am not sure what has changed and what is causing the problem, I hope you can help me with this
    • log.log

      (106.46 kB, downloaded 65 times, last: )
  • Hi,
    Thank you for your inquiry.

    Please note that nrfjprog is not a SEGGER product.
    Therefore, Support is provided by Nordic Semiconductor and not by SEGGER.

    We recommend using J-Flash, SEGGERs professional production utility, which can be uses with a J-Link Plus or higher.

    We will consider this thread as closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.