[ABANDONED] Wireless stack update not working for STM32WB55

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Wireless stack update not working for STM32WB55

    Hello!

    I have been trying to update the wireless stack on a STM32WB55CE MCU using the process described at wiki.segger.com/STM32WB55.
    It seems the the microcontroller is responding well, although I got the following replies while trying to update:

    Update FUS:

    Display Spoiler

    J-Link>loadbin stm32wb5x_FUS_fw_1_0_2.bin 0x0807A000
    Downloading file [stm32wb5x_FUS_fw_1_0_2.bin]...
    HandleBeforeFlashProg() start
    RSS: State idle.
    RSS: Wireless stack erase request started. This process might take a few seconds.
    RSS: Service on-going.
    RSS: State idle.
    RSS: Wireless stack successfully deleted.
    HandleBeforeFlashProg() end
    J-Link: Flash download: Bank 0 @ 0x08000000: 1 range affected (24576 bytes)
    J-Link: Flash download: Total: 0.345s (Prepare: 0.032s, Compare: 0.022s, Erase: 0.000s, Program & Verify: 0.272s, Restore: 0.018s)
    J-Link: Flash download: Program & Verify speed: 88 KB/s
    HandleAfterFlashProg() start
    RSS: searching for a valid image signature in the last 5 unsecured sectors
    First:0x080EF000
    Last: 0x080F4000
    RSS: No valid image or signature found
    HandleAfterFlashProg() end
    O.K.


    And to update the wireless stack:
    Display Spoiler


    J-Link>loadbin stm32wb5x_BLE_Stack_full_fw.bin 0x08057000
    Downloading file [stm32wb5x_BLE_Stack_full_fw.bin]...
    HandleBeforeFlashProg() start
    RSS: State idle.
    RSS: Wireless stack erase request started. This process might take a few seconds.
    RSS: Service on-going.
    RSS: State idle.
    RSS: Wireless stack successfully deleted.
    HandleBeforeFlashProg() end
    J-Link: Flash download: Bank 0 @ 0x08000000: Skipped. Contents already match
    HandleAfterFlashProg() start
    RSS: searching for a valid image signature in the last 5 unsecured sectors
    First:0x080EF000
    Last: 0x080F4000
    RSS: No valid image or signature found
    HandleAfterFlashProg() end
    O.K.



    So it seems that the digital signature of the binaries can not be verified.
    I am using a 512KB STM32WB55, so I adjusted the addresses of the binaries to match the wireless stack release notes, as instructed in the Segger wiki.
    Still, the addresses where the signature is looked for ( 0x080EF000 to 0x080F4000) do not seem to be inside the 512KB range.

    Could these addresses be hard-coded?

    The binaries were downloaded from ST (version 1.7.0 of stm32cubewb).
    I am using version 6.80b of the JLink software.

    Thanks in advance!
  • Hello,

    thank you for your inquiry.

    Do you use custom hardware or an evaluation board? In the latter case which one?
    If custom hardware, do you experience the same problem on an evaluation board?

    Furthermore:
    We recently resolved an issue concerning ST STM32WB55 flash-programming support.
    Could you therefore give the latest version a try (segger.com/downloads/jlink/#J-…twareAndDocumentationPack)?
    Does the behavior improve?

    Best regards,
    Daniel