[SOLVED] MAC7111 locked after Chip Erase

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] MAC7111 locked after Chip Erase

    Hello,

    after Chip Erase JLINK cannot connect to the MAC7111 device any more.
    This is known issue however I havent found any working solution howto perform JTAG recovery.
    When I use Target->Manual Programming->Unsecure Chip it returns "Chip unsecured succesfully" but still cannot connect.
    In the command line the "Unlock Kinetis" does not work since target is not connected.

    I would be grateful for any ideas or hints.
  • I was finally able to connect to the target after lowering JTAG speed from 4000kHz to 400kHz.
    It is odd because normally when there is a program in the flash the target communicates even at 4000kHz. This issue only occurs after Chip Erase command.
  • Hello,

    Thank you for your inquiry.
    Unlock Kinetis may only work for NXP Kinetis target devices and not the MAC7xxx series.
    On many legacy ARM7/9 target devices debug interface speeds are not consistent. So it is possible that this target device has such inconsistency when the device is locked.

    However this is no issue related to J-Link but rather a target specific topic. For more information we recommend contacting the silicon vendor if there is known behavior like this.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.