Disable EZ_Port although hard set through pin

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Disable EZ_Port although hard set through pin

      Hi,

      i got a hardware problem with flashing my board with a Kinetis K22 and the EZP_CS pin.

      I figured out that the problem is that EZ_Port is enabled due to the pin EZP_CS_not low level at boot up.
      The level is set by an external IC because i wanted to use the pin as a input pin.

      My question now is if there is any way to disable the EZ_Port with the Segger J-Link while the pin level enables EZ_Port mode?
      Maybe by writing the FOPT with another technique, early write, workaround, whatever?



      And additionally i read this:
      wiki.segger.com/Kinetis_Series_Devices#EzPort

      The section about EzPort sometimes says RzPort, is this a typo?

      And also, for the Kinetis K22FN1M0 at least, the pull direction is wrong.
      It has an EZP_CS_not which musst be pulled low to activate EzPort.
      Your PullDown suggestion permanently activates EzPort on my K22.
      I dont know about other Kinetis devices.


      Thank you!
    • New

      Hi,

      Thank you for your inquiry.
      To our knowledge the only way to disable the EZPort is by pulling the EZP_CS pin high.
      For information if there is a non-official/undocumented way we recommend contacting the silicon vendor.

      The inconsistencies in the Wiki article were accidental and should be fixed now. Thank you for pointing them out.

      Best regards,
      Nino
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/

      Or you can contact us via e-mail.