[SOLVED] J link ultra+ connection problem

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J link ultra+ connection problem

    I'm trying to connect J link ultra+ debugger to STM32F7xx target board. debugger is new(received yesterday) and I'm using it for first time. I can see it is detected in device manager as J link driver under USB. In STM32cubeIDE I've selected segger J link then pop up comes saying JLink v6.62 firmware restoration - firmware of J link will now be restored....without a valid firmware J link cannot be used.
    please help me to resolve this issue.
  • Hi,
    As you also contacted us via the Ticket system, and the problem seems to be resolved, I will close this thread now.

    The problem was resolved by downloading the latest J-Link Software and Documentation Pack and
    letting it update the J-Link to the latest firmware.

    Please try to keep the flow of information to one channel in the future.
    Otherwise this leads to a higher work load on our side resulting in slower response times.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.