[SOLVED] JLink RT-1052 64MB of QSPI Flash

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLink RT-1052 64MB of QSPI Flash

    I have an RT-1052 with a 64MB of external flash on the QSPI interface, specifically the W25Q512JVEIQ chip if that matters.

    I have the devices.xml file (See "RT-1052-Devies.png" attachment) with the RT-1052 with 64MB and QSPI selected, but the Device List only shows 32MB.
    If I keep everything the same but change the devices.xml to 'fake it' into thinking I want it to use Hyperflash instead it shows 64MB properly (see "JlinkDeviceHyperflash.png").

    Questions: How do I get support for 64MB flash chips on the RT-1052?


    • RT-1052-Devices.png

      278.55 kB, 915×338, viewed 175 times
    • JLinkDeviceHyperflash.png

      171.99 kB, 937×473, viewed 191 times
    • JLinkDeviceList.png

      297.13 kB, 955×591, viewed 170 times
  • Hi Greg,
    Thank you for your inquiry and sorry for the delay in response.
    This should be fixed in the latest version of the J-Link Software and Documentation Pack available here:

    Could you please give this a try?

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.