[SOLVED] Missing JLinkGDBServer for obsoleted XMOS board also containing an ARM core

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Missing JLinkGDBServer for obsoleted XMOS board also containing an ARM core

    I am not able to download a binary USB / J-Link driver for the ARM® Cortex®-M3 core on the xCORE-XA Code Module board. (Discontinued EOL Nov2016). The processor there also has 8 xCORE logical cores, where I am indeed able to do all except flash the code.

    XMOS has explained that I for the ARM part need the JLinkGDBServer [1] (page 239, 242 - I use macOS). However, I don't know where to find JLinkGDBServer.

    Here is my ioreg:


    1. bash-3.2$ ioreg -p IOUSB
    2. +-o Root <class IORegistryEntry, id 0x100000100, retain 15>
    3. +-o AppleUSBXHCI Root Hub Simulation@14000000 <class AppleUSBRootHubDevice, id 0x10000032a, registered, matched, active, busy 0 (17 ms), retain 13>
    4. +-o ... several, like Keyboard
    5. +-o USB2.0 Hub@14200000 <class AppleUSBDevice, id 0x1000074bd, registered, matched, active, busy 0 (6 ms), retain 13>
    6. +-o J-Link@14230000 <class AppleUSBDevice, id 0x1000074d9, registered, matched, active, busy 0 (16 ms), retain 11>
    7. +-o XMOS XTAG-PRO@14220000 <class AppleUSBDevice, id 0x100007507, registered, matched, active, busy 0 (36 ms), retain 17>
    I have written down everything I know about this in a blog note, that I actually started just over this week-end with the purpose of having it as a background here [2]. (There is a table of contents at the top)

    Disclaimer: I might have more than one problem, but I assume it's good practice to resolve those that I have managed to identify first.

    Øyvind Teig

    [1] xTIMEcomposer User Guide by XMOS
    [2] My processor to analogue audio equaliser notes (disclaimer: no money, no ads, no gifts, just fun and expenses, here)

    Update: I have now downloaded and started JLinkGDBServer.app or SEGGER J-Link V6.80a. It will see the ARM's link and say: "A new firmware version is available for the connected emulator- Do you want to update to the lastest firmware version? ". I have not dared to do it yet. Should I? I also have found a ref to the XMOS processor [3]. There is s reference in there to Silicon Labs. I searched for it since XMOS is not in the manufacturer's list in the SEGGER app. When I tried to set it to a Silicon Labs core I got this message from the app: "The connected J-Link (S/N 660003200) has been designed to work with devices made by XMOS only. Debugging the selected device EFM32GG230F1024 is not supported by this J-Link." So, SEGGER has som XMOS knowledge in there some place, but it's not taken out to the app's manufacturer's list. Why not?

    I guess I now know more, but I still would need advice, since I feel just as stuck. There is still no response on ./JLinkGDBServer -if SWD, meaning there is no JLinkGDBServer running. I guess that would be the goal. As mentioned, I do not need to debug any code for the ARM core, I just would like to download the example code. And then I would like the XMOS xflash tool not causing that show stopper. But who knows about the future.

    The details are all in my blog note at [2]. I wanted to update here as well, since this thread should have a complete life outside of my blog world. But if there is no response here then I assume it's no use in just mirroring my own note here. But I desperately need a helping brain.

    [3] XS1-XAU8A-10-FB265 Datasheet
    Øyvind Teig
    Trondheim, Norway
    Home page / blog

    The post was edited 1 time, last by Aclassifier: added an update ().

  • Hi Øyvind,
    Sorry for the delay in response.

    The J-Link you are using is an on board J-Link, and therefore support can only be provided by XMOS.

    SEGGER J-Link never officially supported any XMOS device.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.