[SOLVED] unable to flash/convert my ST-Link V2 to J-Link on my ST NUCLEO-446RE board

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] unable to flash/convert my ST-Link V2 to J-Link on my ST NUCLEO-446RE board

    HI All ,

    I have been trying to flash the STLink-V2 to J-Link on the NUCLEO_446RE board by using all <STLinkReflash.exe>.

    My PC runs on Windows 10. I have both USB SW and Jlink installed .

    However I see the following error repeatedly "
    Preparing for FW update (can take up to 10 seconds)...ERROR: Cannot find an ST-LINK, multiple ST-LINKs plugged in, or ST-LINK is in use"

    Any help in this regard will be appreciated.
    Best regards\ Subhendu
  • Hello ,
    I have got it resolved .Just for benefit for anyone having the same issue . It may be because of an Old ST-Link V2 firmware on the board ( Please be mindful that STLinkReflash.exe works on handful of ST boards )

    Download and use the "STM32 ST-Link UTILITY" from ST in addition to most recent USB drivers like "en.stsw-link009" . Update the USB driver from "en.stsw-link009" , then use the ""STM32 ST-Link UTILITY" for a full system erase . Then update the ST-Link V2 firmware using the utility . :)
  • Hi Subhendu,
    Good to hear that you are up and running again.
    Thank you for sharing this information with the community.

    We will consider this thread as closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.