[SOLVED] JLink Plus v9.3 Not being Recognized on PC

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JLink Plus v9.3 Not being Recognized on PC


    I've using a Windows 10 x64 PC and have been using JLink for developement over SAML22 and STM32 platforms since quite long.
    Since this morning, the JLink is not getting recongnized by my PC.

    I tried changing the USB cable, tried moving it to different USB ports (front and back)
    Tried restarting PC, restarting applications and what not.
    I even tried it on a different Windows 10 x64 PC with no luck.

    The LED flashes green in a fast manner which I guess means that it is currently 'enumerating'.
    Whenever I connect it to the PC, I get a Windows notification saying 'USB Device connected is not recognized'.
    I went to device manager to try updating drivers, but it says latest drivers have been installed.

    Also, since the JLink is not getting detected itself, I see no options when tried runnin JLink Commander, JLink Configurator.

    What could be going wrong here?
    How can I recover the JLink and get it back to work?
  • Hi,
    Thank you for your inquiry.

    Please follow the steps of our troubleshooting guide.
    If this does not help, please note that the J-Link v9.3 is no longer supported by SEGGER.
    Therefore we cannot support you further regarding this.

    We recommend to make use of our trade-in program:

    We will consider this thread as closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.