JLink Plus v9.3 Not being Recognized on PC

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • JLink Plus v9.3 Not being Recognized on PC

      New

      Hello,

      I've using a Windows 10 x64 PC and have been using JLink for developement over SAML22 and STM32 platforms since quite long.
      Since this morning, the JLink is not getting recongnized by my PC.

      I tried changing the USB cable, tried moving it to different USB ports (front and back)
      Tried restarting PC, restarting applications and what not.
      I even tried it on a different Windows 10 x64 PC with no luck.

      The LED flashes green in a fast manner which I guess means that it is currently 'enumerating'.
      Whenever I connect it to the PC, I get a Windows notification saying 'USB Device connected is not recognized'.
      I went to device manager to try updating drivers, but it says latest drivers have been installed.

      Also, since the JLink is not getting detected itself, I see no options when tried runnin JLink Commander, JLink Configurator.

      What could be going wrong here?
      How can I recover the JLink and get it back to work?