[SOLVED] Breakpoint "Skip" feature not working in Ozone V3.10j

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Breakpoint "Skip" feature not working in Ozone V3.10j

    I set up a PC-based breakpoint to skip the first 70 passes through a given instruction. I know it was executed 73 times, but it never broke.

    I'm running Ozone V3.10J with a J-Link Plus (firmware was updated when I installed Ozone V3.10j) under Windows 10 Pro with all updates installed.

    I worked around it by adding a counter that incremented each time the instruction I wanted to break on executed. I put an 'if' statement after the increment that checked for the counter value to be 71 and put a breakpoint there. Worked like a charm.

    I've used the skip feature before and it worked great. Just wanted to let you know that it appears to be broken in the latest version.

    The post was edited 1 time, last by Ron ().

  • Hello,

    Thank you for your inquiry.
    The reported behaviour was reproducible and will be fixed. Sorry for any inconveniences caused.
    For now we recommend using V3.10i until it is fixed.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.