[SOLVED] RTT Auto detection does not search DTCM on STM32H743ZI

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT Auto detection does not search DTCM on STM32H743ZI

    SystemView 3.12, STM32H743ZI with FreeRTOS


    I've placed my RTT buffers in DTCM RAM to keep AXI and cache contention down.

    (The actual address is 0x2001c2f4)

    Unfortunately, the "Auto" search function does not find my buffers.
    I have to enter a manual search range of "0x20000000 131072".

    Could you add the DTCM area to the auto search?

    best regards,
  • Hello Thomas,

    Thank you for your inquiry.
    The DTCM area will be added to the auto search range with the next J-Link DLL update.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.