[SOLVED] IRQ not getting executed in Segger Embedded Studio for ARM V3.4

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] IRQ not getting executed in Segger Embedded Studio for ARM V3.4

    I am using Seggar Embedded Studio for ARM V3.4 and nRF_SDK 12.3.0.

    I am trying to understand interrupts and interrupt handlers.

    The interrupt request for Watchdog timer (i.e. void WDT_IRQHandler(void)) is not getting executed. The control is not going to WDT_IRQHandler.

    I made the following attempts to verify if control was going to the WDT_IRQHandler():-
    1>I tried to switch on the LED
    2>I tried to switch off the LED
    3>Only a printf() statement inside WDT_IRQHandler() (in debug mode)

    The above attempts did not work
    I have defined the following preprocessor definitions:-


    Please let me know if there is some other configuration that is required to be done in seggar. I have attached the main.c and SDK_Config.h files as txt files
  • Hello,

    Thank you for your inquiry.
    For target specific and Nordic SDK specific questions we recommend contacting the silicon vendor directly.

    This thread will be closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.