[SOLVED] Problem with restoring original FW on embOS/IP switch board

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Problem with restoring original FW on embOS/IP switch board

    Dear community,

    I'm trying to restore the original FW on embOS/IP switch board.

    OS: Debian 10.3 / Windows 10
    PCB: V2.0A

    I'm following instructions from ReadMe.txt

    Segger-embOS-SW/Prebuild$ /opt/SEGGER/JLink_V670/JLinkExe -device MK66FN2M0XXX18 -speed 4000 -CommanderScript CommandFile.jlink
    SEGGER J-Link Commander V6.70 (Compiled Mar 27 2020 14:37:00)
    DLL version V6.70, compiled Mar 27 2020 14:36:47

    J-Link Command File read successfully.
    Processing script file...

    J-Link connection not established yet but required for command.
    Connecting to J-Link via USB...O.K.
    Firmware: J-Link OB-STM32F072-CortexM compiled Jan 7 2019 14:09:37
    Hardware version: V1.00
    S/N: 678000124
    Selecting SWD as current target interface.

    Target connection not established yet but required for command.
    Device "MK66FN2M0XXX18" selected.

    Connecting to target via SWD
    Found SW-DP with ID 0x2BA01477
    Unknown DP version. Assuming DPv0
    Scanning AP map to find all available APs
    AP[2]: Stopped AP scan as end of AP map has been reached
    AP[0]: AHB-AP (IDR: 0x24770011)
    AP[1]: JTAG-AP (IDR: 0x001C0000)
    Iterating through AP map to find AHB-AP to use
    AP[0]: Core found
    AP[0]: AHB-AP ROM base: 0xE00FF000
    CPUID register: 0x410FC241. Implementer code: 0x41 (ARM)
    Found Cortex-M4 r0p1, Little endian.
    FPUnit: 6 code (BP) slots and 2 literal slots
    CoreSight components:
    ROMTbl[0] @ E00FF000
    ROMTbl[0][0]: E000E000, CID: B105E00D, PID: 000BB00C SCS-M7
    ROMTbl[0][1]: E0001000, CID: B105E00D, PID: 003BB002 DWT
    ROMTbl[0][2]: E0002000, CID: B105E00D, PID: 002BB003 FPB
    ROMTbl[0][3]: E0000000, CID: B105E00D, PID: 003BB001 ITM
    ROMTbl[0][4]: E0040000, CID: B105900D, PID: 000BB9A1 TPIU
    ROMTbl[0][5]: E0041000, CID: B105900D, PID: 000BB925 ETM
    ROMTbl[0][6]: E0042000, CID: B105900D, PID: 003BB907 ETB
    ROMTbl[0][7]: E0043000, CID: B105900D, PID: 001BB908 CSTF
    Cortex-M4 identified.
    Halting CPU for downloading file.
    Downloading file [embOS_IP_Switchboard_K66.bin]...

    ****** Error: Timeout while preparing target, RAMCode did not respond in time. (PC = 0x00000000, CPSR = 0x20001943, LR = 0x21000005)!
    Failed to prepare RAMCode using RAM
    Unspecified error -1

    Reset delay: 0 ms
    Reset type NORMAL: Resets core & peripherals via SYSRESETREQ & VECTRESET bit.
    Reset: Halt core after reset via DEMCR.VC_CORERESET.
    Reset: Reset device via AIRCR.SYSRESETREQ.

    Script processing completed.

    I'm using the newest J-Link driver/utility
    The same issue is observed on Windows (also with using the newest possible for downloading J-Link drivers - V6.70b
    I did not modified the FW in J-Link OB (I'm using the FW provided with the board).

    Changing -speed to 1000 doesn't help. Please also find the log file attached.

    Could somebody help me with restoring the original FW?
    Thanks in advance for help.
  • Hi,
    Thank you for your inquiry.

    Since your J-Link is still in support period, could you please open a support ticket for this issue?
    Please find all required information in my signature below this message.

    This thread will be closed now to avoid multiple information streams.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.