[SOLVED] J-link commander unspecified error -1

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-link commander unspecified error -1


    I have problem with programming flash S29GL128S (NOR flash) connected to OMAP5912. I am using J-link commander. I am able to configure processor for reading memory. I can read every part of memory, I can also write into RAM, so setting registers is possible. When I try to write into memory, it doesn`t matter if I use loadbin command or w1-4 commands, my writes are ignored. Flash memory space is ofcourse 0c000000 - 0cffffff and also it was declared by exec command (setcfiflash). Flash WP pin is high, which means that writes are allowed. When using command "loadbin" I get "unspecified error -1" What I am doing wrong?
  • Hi,
    Thank you for your inquiry.

    We do not officially support OMAP5912, but OMAP5910, please refer to our "Supported devices" page:

    For what you want to do, a flash loader is required.
    You could implement support yourself via the Open Flashloader.
    For more information, please refer to the following article:

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.