[SOLVED] SystemView won't start recording on Linux without giving any error (works on Windows)

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SystemView won't start recording on Linux without giving any error (works on Windows)

    I am using JTrace Pro Cortex-M with the reference STM32F407 board on Ubuntu 16.04 LTS and this sample - wiki.segger.com/Use_SystemView_without_RTOS

    The issue: when I press 'start recording' button, nothing happens. Not even an error.

    I looked at similar threads (bad shared lib links) but none of these match my issue.

    I have the following packages installed on Ubuntu 16.04 LTS (should be the latest ones) :

    • jlink 6.622
    • ozone:amd64 3.10.5
    • systemview 3.10

    Udev rules are installed properly - Ozone and JLinkGDBServer work.

    SystemView does find the JLink shared libraries which can be seen from the process map via 'cat /proc/$(pidof SystemView)/maps':

    Source Code

    1. 7f0674f4d000-7f06757b5000 r-xp 00000000 fd:01 25821454 /opt/SEGGER/JLink_V662b/libjlinkarm.so.6.62.2
    2. 7f06757b5000-7f06759b4000 ---p 00868000 fd:01 25821454 /opt/SEGGER/JLink_V662b/libjlinkarm.so.6.62.2
    3. 7f06759b4000-7f0676122000 rw-p 00867000 fd:01 25821454 /opt/SEGGER/JLink_V662b/libjlinkarm.so.6.62.2

    Log in SystemView does not show any error either.

    Same setup works on Windows without problems. Any idea what else can be wrong?
  • After additional debugging sessions, even recording via network through ethernet interface does not work. As if the data recording component never runs at all. (connection through network from windows for fine though).

    In strace after pushing the "record" button on linux, some process is spawned, it goes over the devices in /sys subtree, finds USB JTrace device file, tries to talk some packets with it and it ends there.

    Recording on Windows from network with SystemView sometimes works, but you need to be really lucky (specific set network again even though you've already set them last time, SystemView must be freshly opened, and even then it doesn't always work).

    The post was edited 1 time, last by zamniah ().

  • Hello,

    Thank you for your inquiry.
    We are aware of the issues under Linux and macOS and are currently working on a fix.
    To stay up to date with releases you can subscribe here:

    Sorry for any inconveniences caused.

    EDIT: Fix is released.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.