[SOLVED] Ozone on macOS becomes unresponsive after some time.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Ozone on macOS becomes unresponsive after some time.

    Hello all,

    I've been using Ozone on macOS for a number of projects. It seems that after a while a lot of the application ceases functioning. I can still interact with the UI but the operations seem to have no effect. For example new breakpoints don't take effect, or watched data ceases to update. Using the reset or stop / start debug buttons does nothing. Even quitting the application is impossible. I can select "Quit Ozone" from the menu and I get the "Close this session?" prompt but after clicking "Yes" nothing happens. The only way to get out of this state is to force-quit Ozone. Then once it is restarted, everything works again. The really annoying thing about it is that I lose all of my session state. Any windows I moved or new watched data I added is reset to the state it was in when I first started the session.

    Has anyone else experienced this and know the cause, or is there something I can look at to figure out why this happens?

    I'm currently on version 3.10d but this same behaviour has happened on other versions.
  • Hello,

    Thank you for your inquiry.
    We received your message in parallel via our support system. To make sure not information is lost between the channels this thread will be closed now.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.