[SOLVED] Systemview - SYSidle counter stuck to "1"

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Systemview - SYSidle counter stuck to "1"

    Hi All,
    I am evaluating sysview on a CM4 using a custom OS.
    It can be approximated to a fixed scheduler inside a macro loop, time triggered.
    At the very end of the "tasks" handling, I wait for the tick to elapse and here I am placing the function call "SEGGER_SYSVIEW_OnIdle()"
    Nevertheless, I can see that cpu load section the counter IDLE counter is never increased.
    Any hint on this topic?
    Best regards,
  • Ok,
    figured out by trial and error that "probably" the SEGGER_SYSVIEW_OnIdle must be called only when after tasks have been placed in SEGGER_SYSVIEW_OnTaskStopReady .
    Otherwise the GUI is not able to perform computation correctly.
  • Hello,

    Thank you for your inquiry.

    How SEGGER_SYSVIEW_OnIdle is to be used is explained in SystemView manual section
    Section 6.1. explains the general implementation steps.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.