[SOLVED] J-link flashloader qspi 4 byte mode

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-link flashloader qspi 4 byte mode

    I am using a STM32F769NI + micron MT25QL512 64MB memory which uses the ST_STM32F746G_Disco_QSPI.elf

    It works fine until I set the qspi to use 4 byte mode, after which it requires a power cycle to the board to connect.

    Is source available for this elf? Or is there some other workaround?
  • Hi,

    Thank you for your inquiry.
    Generally the flash loader provided by us works with the eval board with default configurationsIf you want to use another mode you will have to edit the flash loader.

    I sent you a PN with the link to the sources.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.