[SOLVED] unresolved reference with STM32CubeIDE ( Eclipse based IDE)

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] unresolved reference with STM32CubeIDE ( Eclipse based IDE)


    I am trying to get FreeRTOS v 10.0.1 to run with SEGGER SystemView v3.1. I have copied and implemented the source and header files according to the SEGGER manual. Sadly I get an unresolved reference error with the SEGGER_RTT_ASM_WriteSkipNoLock() function although I have added the new folders to my include paths. As I have searched the internet for possible solutions, I am stumbled over the "improper linking". So that I need to do a manual linking of the new source files?
    I tried to set the new folders as a library linking path but then get an -lC error where my console tells me the path is not found. I think I am doing here something really wrong and would appreciate some help, as I think this might be a very simple fault on my side.

  • Hello Benjamin,

    Thank you for your inquiry.
    Please understand that STM32CubeIDE is not a SEGGER product so we can't provide assistance in the setup of generic build projects.
    We recommend contacting ST support in this regard as this is a generic IDE question and is not related to SystemView.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.