[SOLVED] J-Link Base troubles to connect to CYW43907

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link Base troubles to connect to CYW43907


    I'm working on a USI module (WM-AN-BM-23) which embeds the CYW43907.
    I have troubles to connect to it. I've attached two pictures where I'm monitoring SWDCLK pin and reset pin.
    The good behavior is when the reset pulse is occuring right after there is activity on SWDCLK pin.
    The bad behavior is when the reset pulse occurs after few seconds, after the JLink commander gives up in connecting to the target.

    The issue that to have the good behavior is that I have to do the reset down manually. Normally (as it is shown in the bad behavior), the reset pin is connected to pin 15 of the Jlink.

    Are you aware of such a behavior with this kind of target?

    • P1722_reset_pin_not_working.jpg

      329.97 kB, 2,001×1,097, viewed 30 times
    • P1722_reset_pin_working.jpg

      282.19 kB, 2,000×949, viewed 25 times
  • Hi,
    Thank you for your inquiry.

    We tried to reproduce the issue.
    On the BCM43907 / CYW43907 WICED kit everything is working as expected.

    As we also answered your questions in our support ticket system we will consider this case as closed now.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.