[ABANDONED] How to use jlink to program cypress chip CYPD3175

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] How to use jlink to program cypress chip CYPD3175

    I can't use the jlink base to flash the cypd3175 chip of cypress. The version of jlink is v10, and the version of jflash on windows is the latest.

    The use of jflash can only perform these operations after the flash is erased. If it has been burned, jlink will not connect anymore. I tried using cypress's miniprog3, and I confirmed that the hardware connection is good There is no problem with the hardware. There is no problem that it cannot be burned once. At the same time, I noticed that there is a toggle power in the cypress programming. I tried to set this on jflash. After trying, I found that after using the target power supply, the returned content of jflash was a little different, but it still failed and could not be connected. .
    Images
    • menu.saveimg.savepath20191220191824.jpg

      101.96 kB, 911×706, viewed 65 times
  • Hi,
    Thanks for your inquiry.
    Such an issue is not known to us.


    Could you please send us a J-Link log file? How to enable:
    wiki.segger.com/J-Link_DLL#Enable_J-Link_Log_File
    Could you send us a data file to reproduce this issue (e.g. .hex-file)?

    Best regards,
    Fabian
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/


    Or you can contact us via e-mail.