[SOLVED] J-Link software V6.60 causes "target disconnected. Not a directory" error.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link software V6.60 causes "target disconnected. Not a directory" error.

    Just updated the software to V6.60, which also updated the firmware on my J-Trace Pro.
    My firmware seems to load fine on the target, from STM32CubeIDE, through JLinkGDBServer.exe.
    But as soon as loaded the server closes down and the IDE shows a message saying: Target disconnected. Not a directory. ?(

    Downgraded the software to V5.56d (leaving the new firmware on the J-Trace alone). Everything works fine again. ;)
  • Hello Giuseppe,

    Thanks for providing the log file.
    Is this file from start of the debug session until the end of it?
    It looks a bit cut off...
    Usually, one of the last actions should be "GDB closed connection. Shutting down..."
    However, here it is cut off somewhere in the middle but without any error indication etc.
  • Thank you Alex, for investigating this issue.

    The log file attached is all the GDB server created when trying to start a debugging session.

    I suspect the log appears to be cut off because the server shut down unexpectedly.
    I have tried again this morning and got a similar result, with the last line in the log saying "... Restoring RAMCode".

    I said in my first post "My firmware seems to load fine on the target". Actually, this is not quite correct. I apologize.
    Here is exactly what happens with the loading popup window:
    the Compare progress bar reaches 100%, then, before the Erase progress bar starts filling up, the server shuts down.

    Hope this may be useful.
    Please let me know if there is anything else I can do to help you with this analysis.