[SOLVED] No MCU detected in KEIL

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] No MCU detected in KEIL

    Drivers 6.14-6.54. KEIL does not detect the STM32F030F4 processor. When change the debugger from J-Link to ST-Link, the processor is detected. The oscilloscope does not detect SWD activity.
    The cause of the malfunction - in the KEIL settings, the processor is selected as "STM32F030F4Px" and this name is written in the settings file "project.uvprojx" in the parameter
    <Device> STM32F030F4Px </Device> "
    As a result, J-Link does not find this type of processor and puts "ARM7" (info in the J-Link control panel).
    If in the file "project.uvprojx" in the TargetCommonOption/Device settings change the name from "STM32F030F4Px" to "STM32F030F4", then J-Link starts to find the processor and the processor type "STM32F030F4" is displayed in the J-Link control panel.
    • jl.png

      71.74 kB, 626×465, viewed 66 times
  • Hi,
    Thank you for your inquiry.

    We will change this behavior in the next release planned for tomorrow.
    It should all work as expected then.

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.