[SOLVED] ST-Link Reflash Utility

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] ST-Link Reflash Utility

    Hi,

    First of all, I have STM32F446RE Nucleo-64 board.

    Is there any way to use ST-Link Reflash Utilty in Linux(Ubuntu 16.04) ?
    I tried to run with wine. It works but I get some errors like below

    Preparing for FW update (can take up to 10 seconds)...ERROR: Cannot find an ST-LINK, multiple ST-LINKs plugged in, or ST-LINK is in use

    Thanks for helps.
  • Hello,

    Thank you for your inquiry.
    The reflash utility is only available for Windows. Linux or mac versions are not planned.

    When using a VM make sure that USB devices are forwarded correctly to the VM. For more information consult the VM supplier.

    Best regards,
    Nino
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.