J-Link on-board debugger does not work with SES

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • J-Link on-board debugger does not work with SES

      Hello,

      I try to use the on-board ST-Link to work as J-Link Debugger at NUCLEO-STM32L432KC board.

      I followed the instructions in the Converting_Guide and everythink seems to work.

      I used the J-Link Commander to verify the conversion process (for me it looks pretty good :) ).


      Then I programmed my device with J-Flash Lite without any problems :) .


      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

      Now, I tried to debug a small sample project with SEGGER's embedded Studio.

      But immediately after I try to "Start Execution" I get the following error message.


      I also stored the J-Link log file (please see attachments).

      There are listed the following errors.

      Brainfuck Source Code: LOG.txt

      1. ***** Error:
      2. T347C 001:168.980 Programming failed @ address 0x08004808 (program error)
      3. T347C 001:169.052 -- End of flash programming
      4. T347C 001:169.124 -- Start of restoring
      5. T347C 001:169.194 -- Restoring RAMCode
      6. T347C 001:176.427 -- Restore target
      7. T347C 001:176.541 -- Restore memory
      8. T347C 001:176.613 -- Restoring CPU registers
      9. T347C 001:176.716 -- End of restoring
      10. T347C 001:176.793 Restarting due to program error (possibly skipped erasure of half-way erased sector).
      11. T347C 001:176.840 Skip optimizations disabled for second try.
      12. T347C 001:176.888 -- --------------------------------------
      13. T347C 001:177.987 - 304.390ms returns -3
      14. T347C 001:272.209 JLINK_IsOpen()
      15. T347C 001:272.242 - 0.037ms returns 0x01
      16. T347C 001:286.341 JLINK_Close()
      17. T347C 001:286.706 -- CPU_ReadMem(4 bytes @ 0xE0001000)
      18. T347C 001:301.497 - 15.175ms
      19. T347C 001:301.522
      20. T347C 001:301.532 Closed
      Display All
      Here are my J-Link options.



      --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

      After that, I tried to use the on-board J-Link to debug a CubeIDE Eclipse Project. This works without any problems. So It seems to be an SES option issue for me.

      Best Regards!
      Files
      • LOG.txt

        (17.53 kB, downloaded 12 times, last: )

      The post was edited 2 times, last by ecom ().

    • New

      Hi,
      Thank you for your inquiry.

      We gave it a quick try and everything is working fine on our side with the NUCLEO-STM32L432KC.
      Please find the test Project we used attached.

      Could you please try it with that one and check if it works?

      BR
      Fabian
      Files
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/


      Or you can contact us via e-mail.
    • New

      Hello Fabian,

      Thanks for your reply! I got the same error with your test code.

      BUT: When I reset the device (via reset button at eval board) while programming, it seems to work after a few tries... ?(

      The curious thing is, that this behavior appeared with three different boards... After the board works one time, it always works without any troubles. How can it be?

      Best regards