[ABANDONED] Open Flashloader Read past 1MB errors

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [ABANDONED] Open Flashloader Read past 1MB errors

    I have implemented a Segger Open Flashloader and I have a 2MB (0x200000) external flash mapped to base address 0x00000000. In jlink, when I do a savebin f.bin 0x00000000, 0x200000, I have found that it won't read more than 1MB.

    I have implemented the SEGGER_OPEN_Read() function. After I was getting this error, I did a test by doing the read function as follows:

    int SEGGER_OPEN_Read( U32 Addr, U32 NumBytes, U8 * pDestBuff )
    return NumBytes;

    Now I still get exactly the same error.

    I have attached a log file with the log from when I was actually reading my flash, but it is exactly the same with the minimal SEGGER_OPEN_Read function.

    J-Link>savebin flash.bin 0x00000000 0x200000
    Opening binary file for writing... [flash.bin]
    Reading 2097152 bytes from addr 0x00000000 into file...Not all bytes could be read from target. 0x00100000 bytes successfully read.

    Is there any known limits to the read size?
    • log.txt

      (2.01 kB, downloaded 37 times, last: )
  • Please note that the savebin command does not go through any flash loader routines.
    It simply performs a ReadMem() access from the specified address.

    Is your flash memory mapped readable?
    Or is it some kind of SPI flash etc. that is not mapped in the address space of the CPU but instead needs to be read by feeding commands etc. to an SPI controller?