stm32g431 J-Link error "Failed to measure CPU clock frequency"

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • stm32g431 J-Link error "Failed to measure CPU clock frequency"

      Hi All,

      I try to start work with relatively new chip STM32G431, but Ozon stopped working with "Jlink reports unspecified download error"

      I tried to use jlink command line and erase chip but it also fails.

      In log I can see "Failed to measure CPU clock frequency".

      Any clue what can I do now?


      • log1.txt

        (8.62 kB, downloaded 17 times, last: )
      • log2.txt

        (6.04 kB, downloaded 16 times, last: )
    • Hi Pawel,
      Thank you for your inquiry.

      Such an issue is not known to us.

      Could you give us a step-by-step explanation on how to reproduce this issue?

      Best regards,
      Please read the forum rules before posting: Forum Rules

      Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system:

      Or you can contact us via e-mail.
    • Hi Fabian,

      I build basic project using CubeMX that worked OK with Segger tools. Then I added RTT/SystemView and after download using Ozon I couldn't connect and erase chip by any Segger tool.
      I didn't have this type of problems with other STM32 chips.

      ST-Link works OK.

      To reproduce download included .hex to stm32g431cb