[SOLVED] Ozone 2.70a: unable to get Project.RelocateSymbols() working

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Ozone 2.70a: unable to get Project.RelocateSymbols() working

    Running on Windows 10. Have a project set up for debugging u-boot (target i.MX6 Solo), and need to offset the debug symbols after relocation of u-boot. However it doesn't seem like the Project.RelocateSymbols() takes any effect. I've tried calling it from a script function as well, to check the return value, and it is 0. After I have loaded the project, run initialization of ddr registers etc I can debug fine until relocation.

    I've used the following commands from the command line, with no errors returned, but the addresses still reflect the original symbol locations, e.g. disassembly or addresses of breakpoints being set.


    From my understanding of reading the documentation, this should be what is needed. Or have I overlooked anything?
  • Hello,

    Thank you for your inquiry.
    We were able to reproduce the issue. There was an error in how the command was handled.
    It will be fixed in the next Ozone version.
    There will be two limitations when this command may be used.
    1. it must be called before File.Open.
    2. It can't be used during rutime of the target application.

    To stay up to date with Ozone you can subscribe here:

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.