[SOLVED] Ozone FreeRTOS Awareness Issues

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Ozone FreeRTOS Awareness Issues


    Today I tried out FreeRTOS Awareness in Ozone 2.60p.
    I can load the plugin and the tasks view will show the tasks.
    According to the website, I should be able to see the the current state of any task (call stack, register window, local data) when selecting a task in the view.
    This is not working. The views stay the same every time.

    Then I downloaded the newest version of Ozone (2.70a).
    Now FreeRTOS Awareness doesnt work at all. I can not even see the tasks.

    I am using FreeRTOS v9 running on an Cortex R4 MCU.
  • Hello,

    Thank you for your inquiry.
    Currently Ozone ships only with FreeRTOS scripts for Cortex-M3, M4, M7, ARM and Cortex-A9.
    R4 is not provided yet.
    However you can simply use either the CA9 or ARM script as base and create your own for Cortex-R4.

    They are written in Javascript. The API is explained in the Ozone manual in section 6.2

    Best regards,
    Please read the forum rules before posting: Forum Rules

    Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.