[SOLVED] No RTT Output in Debug Terminal on MacOS

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] No RTT Output in Debug Terminal on MacOS

    I am using SEGGER Embedded Studio for ARM Release 4.22 Build 2019090301.39946 for macOS x64.
    I am interfacing to a Nordic PCA10040 development board using a USB cable.When I run the Nordic SDK 15.3.0 ble_app_beacon
    sample project, from Segger Embedded Studio, I can successfully launch it, hit breakpoints, and step through code.

    But I never see anything in the SES debug terminal despite the fact that the main.c method has:

    NRF_LOG_INFO("Beacon example started.");

    My sdk_config.h has the following settings:


    With the above settings applied to enable UART, I can always see debug output just fine using a separate terminal program to monitor the serial port on my MAC.And if I separately run JLinkExe -if SWD / JLinkRTTClientExe on my Mac, I also see RTT debug output in that window just fine.But I never ever see debug lines in the SES Debug Terminal, even if I stop JLinkExe/JLinkRTTClientExe, stop the terminal program looking at the serial port and change my sdk_config.h to disable #define NRF_LOG_BACKEND_RTT_ENABLED 0, then restart SES and launch a new debug session.

    What could be wrong with my Segger Embedded Studio setup such that I do not see any output in the SES Debug Terminal?

    The post was edited 1 time, last by davidgyoung ().

  • Thanks for the response, @awnell. I have confirmed that the fix posted by @kklobe in the link you have above works. Here's what he wrote:

    Nordic has posted a fix for this in


    You need to change a line in your sdk_config.h from




    I hope that helps.