J-Scope issues

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • J-Scope issues

      Dear Segger team,

      for evaluation purposes I installed J-Scope V5.10d and tried it out with some example code running on an ARM Cortex-M7 controller.
      I think J-Scope is a really powerful tool for debug and qualification purposes, but I found also some inconveniences. Maybe I used it incorrectly, but maybe it is a property of the tool which is worth to be improved.

      1) I have an array of floating point numbers. These are displayed correcly.
      a) If I reload the project after a restart of J-Scope, it claims that "the selected symbol could not be found in the application file". This message is shown for all elements in the array I had added.
      b) If I export the data to a CSV file, the floats are not exported correctly. It seems that the binary pattern is reinterpreted as integer number.

      2) After I have added new variables to the application and the ELF file has changed, it is not recognized by J-Scope. (Maybe caused by the first issue?)
      a) The addresses of already added variables do not change accordingly.
      b) The new variables do not appear in the symbol list.

      3) In the J-Scope XML file there are absoulte paths to the source files of the variables stored. This is not handy if the project should be shared among different people with different project locations on their hard disks.
      When I changed the absolute path to a relative paths (in relation to the ELF file / in relation to the jscope file), also the following message appears after reload: "The selected symbol could not be found in the application file."
      A relativ location of the ELF file is accepted.

      4) When I use J-Scope in parallel with my CrossWorks IDE, sometimes a message appears saying that the J-Link firmware needs to be updated. Then an firmware update is performed (always to the version which should have been installed before).
      This is probably not intended...

      5) The "Legend" is not resizable and variable names are truncated after 9 characters. This is problematic if the variable names start with the same letters.

      6) If the target controller is not specified when the project is initially created, J-Scope will always ask for the controller when I want to connect to the target. So, it gets not stored to the jscope file.

      Can you confirm these issues?

      Thanks in advance.
      michaeL
    • Hello Michael,

      could you please try the current beta version v6.11m?
      This version has lots of improvements and should solve at least some issues.

      The request for a firmware update should not happen. But this is more an issue with the J-Link software. J-Scope itself does not care about firmware updates.
      Are you using the latest release of the J-Link software (v6.52)?

      Best regards
      Arne